Instale o Google Chrome no Kali Linux

Google Chrome: instalado no sistema operacional Kali Linux

Neste breve artigo, vocĂȘ verĂĄ como pode facilmente instale o Google Chrome no seu sistema operacional Kali Linux. VocĂȘ tambĂ©m verĂĄ alguns erros que podem ocorrer durante a instalaçãoe quais sĂŁo as maneiras de lidar com eles.

Nota: Para instalar, vocĂȘ precisarĂĄ do cĂłdigo do SuperusuĂĄrio ou do acesso da conta do administrador (raiz).

>> O sĂ­mbolo “# ” antes que o comando declare que, para executar o comando, vocĂȘ deve ter direitos “root” ou usar o comando sudo.

>> O sĂ­mbolo “$ antes do comando declarar que vocĂȘ nĂŁo precisa de privilĂ©gios privilegiados para executar este comando.

Baixar:

Use o comando wget para baixar o pacote Debian mais recente do Google Chrome. Para fazer isso, abra um terminal e digite:

# wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

Instalação:

A maneira mais fĂĄcil de instalar o Google Chrome Ă© usar o gdebi, que farĂĄ o download de todos os pacotes necessĂĄrios. Para instalar o gdebi, abra um terminal e digite o seguinte comando:

# apt install gdebi-core

Em seguida, instale o pacote debian que vocĂȘ baixou anteriormente:

# gdebi google-chrome-stable_current_amd64.deb

Começar:

Para iniciar o programa, primeiro abra um terminal e digite:

$ google-chrome –no-sandbox

Erros:

1. No SandBox: ERRO: zygote_host_impl_linux.cc (89)]A execução como raiz sem –no-sandbox nĂŁo Ă© suportada.

A Ășnica maneira de evitar esse problema Ă© executar o Google Chrome com uma extensĂŁo -no-sandbox, conforme mostrado abaixo:

# google-chrome –no-sandbox

2. Instrução ilegal: A mensagem “Instrução ilegal” aparece quando vocĂȘ executa o comando google-chrome como um usuĂĄrio root privilegiado.

Para lidar com o problema, vocĂȘ precisa criar outro usuĂĄrio privilegiado, por exemplo: linuxconfig. Para criar outro usuĂĄrio, digite:

# useradd -m -d / home / linuxconfig linuxconfig

Em seguida, execute o Google Chrome novamente, usando o novo usuĂĄrio linuxconfig:

# su linuxconfig -c google-chrome

3. O pacote libappindicator1 nĂŁo estĂĄ instalado: dpkg: problemas de dependĂȘncia impedem a configuração do google-chrome-stable: google-chrome-stable depende do libappindicator1; Contudo: O pacote libappindicator1 nĂŁo estĂĄ instalado.

Para evitar esse problema, vocĂȘ precisa usar o gdebi para instalação, como mencionado anteriormente.